原标题:CentOS下安装php7

Dokuwiki官网对php版本的要求是5.6+,yum上的版本5.4.x,干脆从php官网安装最新版本php。

Step1. 手动安装php7

#yum安装libpng-devel

#yum安装libjpeg-devel

#yum install libxml2

#yum install libxml2-devel

#./configure –prefix = / usr / local / php7 \

–with-gd \

–with-openssl \

–with-apxs2 =的/ usr /本地/ Apache / bin中/ apxs的

#make

#make install

make install之后提示我执行下面这条

#libtool –finish /usr/local/src/php-7.2.2/libs

Step2. 配置php

#cd /usr/local/php7/src/php-7.2.2/

#cp php.ini-development /usr/local/php7/lib/php.ini

检查httpd.conf配置文件

LoadModule php7_module模块/ libphp7.so

<FilesMatch“\ .ph(p [2-6]?| tml)$”>

    SetHandler应用程序/ x-httpd-php

</ FilesMatch>

<FilesMatch“\ .phps $”>

    SetHandler应用程序/ x-httpd-php-source

</ FilesMatch>

尝试创建phpinfi.php文件,从浏览器打开看看安装是否成功

<?php phpinfo(); ?>

发表评论

电子邮件地址不会被公开。 必填项已用*标注